Index     FAQ      Search

It is currently Wed Dec 13, 2017 12:22 pm




Reply to topic  [ 40 posts ]  Go to page Previous  1, 2
 MEMS 2J 
Author Message
 Post subject: Re: MEMS 2J
PostPosted: Wed Jul 12, 2017 10:59 pm 
Newborn - handle with care


Joined:
Fri Jul 07, 2017 4:42 pm
Posts:
3
Pscan running nicely on my very sick Rover Mini MPi with MEMS 2J but I'm unsure of what the cam sensor should read - nothing at moment.

The car barely runs, rough as hell, it first lost loads of power, got hot like badly out ignition, then gradually got rougher til the point it hardly runs and sure doesn't move. So I'm looking for the cause. No silly error codes found, just oil temp sens and ambient temp sens. Live oil temp reads OK, think no amb sensor fitted. Crank sensor says reading OK but nothing from the cam sensor - should it be showing a signal? I think so but need some confirmations of what I'm expecting to see.

Lambda reading 97-100% correction, what does that mean?

Already tried a spare cam sensor (no diff) and continuity tested wires back to MEMS unit all OK. Some breakdown of sensor cable screening braid needs fixing but don't think that would cause total loss of signal?

Also tried spare MAP sensor, idle solenoid, traced all those wires back to MEMS all OK. No difference.

Any bright ideas?

Thanks, Pete.


Offline
  Profile  
 
 Post subject: Re: MEMS 2J
PostPosted: Thu Jul 13, 2017 1:25 pm 
Rovertech Kiloposter


Joined:
Mon May 13, 2013 10:02 pm
Posts:
1264
Location:
Cheshire
I don't think the cam sensor is the reason for poor running.

Here are some extracts from the RAVE manual.

IGNITION SYSTEM

The ECM determines the optimum ignition timing based on the signals from the following sensors:
1. Crankshaft position sensor - Engine speed and crankshaft position
2. Manifold absolute pressure sensor - Engine
load
3. Engine coolant temperature sensor - Engine temperature
4. Throttle position sensor - Throttle pedal released

The engine management system uses no centrifugal or vacuum advance. Timing is controlled by the ECM which is energised by the main relay, located within the relay module. Spark distribution is achieved by a direct ignition system which consists of a twin-ignition coil driven directly from the ECM.

Camshaft position sensor

The camshaft position sensor has two functions. The first is to enable the ECM to run a sequential fuelling mode. The second is to measure the actual cam period, this measurement is achieved using teeth on the camshaft to indicate when the valve opens and closes. If the camshaft position sensor fails when the engine is running, the engine will continue to run normally in sequential fuelling mode. If the sensor fails before the engine is started, the engine will start but run at a reduced rev limit in comparison to the normal rev limit of 6500 rpm.


Are the plugs, leads, and coil pack all healthy?

_________________
Rover 200 BRM Turbo
MG Maestro Turbo


Offline
  Profile Feedback  
 
 Post subject: Re: MEMS 2J
PostPosted: Thu Jul 13, 2017 11:04 pm 
Newborn - handle with care


Joined:
Fri Jul 07, 2017 4:42 pm
Posts:
3
Thanks for your comments.

After more messing today there is a good connection between MEMS plug and cam sensor on both wires but it's still not getting any signal for both sensors I've tried. I agree it looks like there may be another fault causing the really bad running as well.

As the car will barely idle and pops and bangs (with no increase in revs) as soon as the throttle is opened I'll keep looking at the obvious faults first like checking with a spare ignition pack. I understand MEMS also uses the ignition advance to smooth the idle- clearly not working. The ignition timing figure on live data seems to be about 5-7deg but no idea if that's accurate.

Need to check fuel rail pressure too plus check the flywheel reluctor ring hasn't moved both of which are plausible causes. Don't have a spare good crank sensor to try but resistance seems OK (c 1.5k ohm) compared with no measureable connection on a dead one.

No concerns over the recent plugs. It runs on all cylinders whilst warming up but conks out when warm so not really suspecting ign pack or plugs, more something affecting the control of them.

Once whatever else is wrong perhaps I go back to the cam sensor problem. Assuming it's not the MEMS unit that's croaked of course.

Well, well this has turned into a proper long winded detective job!

After having several carb minis I love the MPi with its more recent control but can totally understand why some people don't like em when they go wrong!

Pete


Offline
  Profile  
 
 Post subject: Re: MEMS 2J
PostPosted: Wed Jul 26, 2017 10:50 am 
Newborn - handle with care


Joined:
Fri Feb 24, 2017 11:20 pm
Posts:
1
Only just ran the last update.

Mini MPi built June 2000, exactly the same identifiers as zone11.

I can confirm that oil temp data is exact copy of coolant temp. Oil temp sensor is only connected to the gauge as previously mentioned.


Offline
  Profile  
 
 Post subject: Re: MEMS 2J
PostPosted: Sat Aug 12, 2017 1:16 pm 
Newborn - handle with care


Joined:
Fri Jul 07, 2017 4:42 pm
Posts:
3
A brief update on the cam sensor returning an "invalid" reading and ridiculous cam angle number through Pscan on my rover mini.

Turns out the flywheel had moved 140 deg out (and I suspect had been fitted by last numpty at 180deg out) with broken key washer and loose bolt with very messy boss taper. Amazingly the thing was still struggling, running and idling until it got so far out it was trying to fire about 150 deg BTDC then gave up.

Sorted new boss, flywheel mounted correctly and it all works sweetly with everything reading OK.

Lesson learnt - if cam sensor doesn't read but cam and crank sensor and wiring (and everything else!) are all OK, suspect flywheel is 180deg out or at least significantly out so MEMS thinks the cam reading is invalid. Actually the cam reading can be right (as in my case) and the crank reading wrong but it automatically ignores the cam sensor in favour of crank priority.

Loose flywheels are much more common on minis than I thought...

Total success for Pscan so far - now to program a new to me spare key fob :roll: :thumbup:


Offline
  Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 40 posts ]  Go to page Previous  1, 2


 Who is online 

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

 
Index  |  FAQ  |  Search

Content © Rovertech - Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group