Index     FAQ      Search

It is currently Mon May 28, 2018 11:07 am




Reply to topic  [ 14 posts ] 
 MG zs TD running problems 
Author Message
 Post subject: MG zs TD running problems
PostPosted: Sat May 06, 2017 4:29 pm 
Newbie


Joined:
Sat May 06, 2017 3:26 pm
Posts:
8
Hello all hope some1 can help me I've got the paper clip mod egr delete de-cat sdi's and rear backbox. I had a pump fault with timing solenoid on injection pump so I fitted a second hand injection pump with new belts and water pump. I keep getting a maf sensor fault and egr fault and the car has no power above 3000 revs it coughs and splutters with a pop and bang then a cloud of blue or white smoke I'm £400 in and and loosing my patience with the car now was running perfect for 2 weeks after fitting injectors then I got pump fault so did the above to still have same symptoms but no fault code can any1 plz help me


Offline
  Profile  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Sat May 06, 2017 6:16 pm 
RT GOD

User avatar

Joined:
Sat Feb 22, 2003 10:56 pm
Posts:
15740
Location:
Saath
Unplug the maf, the light will stay on but should be fine.

_________________
Paul
White ZR Turbo - gone - but new one on its way...

Image


Offline
  Profile Feedback  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Sat May 06, 2017 6:26 pm 
RT GOD

User avatar

Joined:
Tue Jul 21, 2009 5:09 pm
Posts:
8860
Location:
Newcastle
Well I don't even know what the paper clip mod is? Unless your on about the fault code one??? What boost you running? As you usually go to 19psi after those mods, did the timing get set up properly? But yeah unplug the maf and see how it feels.

_________________
ImageImage

Thread
viewtopic.php?f=10&t=121423


Offline
  Profile Feedback  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Sat May 06, 2017 6:31 pm 
Newbie


Joined:
Sat May 06, 2017 3:26 pm
Posts:
8
My maf is already unplugged the paper clip mod bridges pin 1 and 5 to make the car think the maf is there. I don't know wat boost I'm running as I don't have a boost gauge


Offline
  Profile  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Sat May 06, 2017 6:39 pm 
Newbie


Joined:
Sat May 06, 2017 3:26 pm
Posts:
8
As soon as I hit between 3000 and 4000 rpm all power vanishes and just splutters like I'm running out of fuel then it will make a big bang like backfire then puff of smoke. I thought it was down to the pump so I replaced the pump and it's still there which is annoying coz I don't have a fualt code for pump now


Offline
  Profile  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Sun May 07, 2017 6:59 pm 
Newbie


Joined:
Sat May 06, 2017 3:26 pm
Posts:
8
Just an update I took of all intercooler pipes and checked them all is fine. Cleaned my crank position sensor aswell. Gonna bleed injectors incase there is air in system and check my earth cable from battery to slam panel hopefully in the next few days. Still after some advice on the above if any1 can help it will be much appreciated or if any1 wanted to come have a quick look I'm in market weighton yorkshire


Offline
  Profile  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Sun May 07, 2017 11:06 pm 
Rovertech Kiloposter


Joined:
Fri Jan 09, 2004 11:42 am
Posts:
1356
Location:
devon
if you have a paper clip in place of the maf, firstly it is a dead short and will no doubt damage the ecu as the maf would have a resistance in it, also if the ecu thinks the maf is there and its not then the fueling will be set to near zero as it will not sense any air going into the engine, if however the ecu knows the maf is not there it will run a default map of fuel and run okish, so basiccaly remove the paper clip and try again.

_________________
BUILDER OF THE FIRST 2.2. dohc vtec Rover 600 ever built.
2.2 Vtec Rover 600 (sold :-( )
Rover 200 vi(now full T16 225bhp) (ours)
Mg zs180 Black (wifes)
Mk2 Rover 45 113se td (my Toy)


Offline
  Profile Feedback  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Mon May 08, 2017 6:57 am 
Newbie


Joined:
Sat May 06, 2017 3:26 pm
Posts:
8
Ok I'll get another maf and see wat happens


Offline
  Profile  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Tue May 09, 2017 12:20 am 
Silver Trader

Silver Trader

Joined:
Mon Feb 04, 2008 10:38 pm
Posts:
208
It won't hurt the ecu, it's got protective circuitry on the input pins to not only prevent damage but also logic to help to recognise the fault - but I'm also going to vote that the paperclip is perhaps making a bit of a nuisance of things. The ECU has plausability checks for realistic maf behaviour and a permanent 'logic 1' signal is quite easily identified as 'false'.

As you're losing power past 3000 rpm, I would assume the ecu has recognised the maf sensor as faulty and put you in limp mode. This will give very good drivability at lower revs but will limit fuel delivery to below normal levels after 3k and eventually taper to nothing.

Get a valid maf signal and then see what (if any) problems remain.

_________________
DieselPowered Engine Tuning

Producing the highest power diesel rovers you're likely to see :D


Offline
  Profile Feedback  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Tue May 09, 2017 2:44 pm 
Newbie


Joined:
Sat May 06, 2017 3:26 pm
Posts:
8
Thanks for advice I'm in process of sourcing a maf sensor. It doesn't just loose power it pops and back fires 2 with a puff of smoke


Offline
  Profile  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Wed May 10, 2017 3:00 am 
Silver Trader

Silver Trader

Joined:
Mon Feb 04, 2008 10:38 pm
Posts:
208
Yeah you might have something else going on too (fuel starvation, dodgy egr valves etc spring to mind)

Because troubleshooting electronically controlled cars can be tricky, i just tend to advice to fix known first just to reduce variables

_________________
DieselPowered Engine Tuning

Producing the highest power diesel rovers you're likely to see :D


Offline
  Profile Feedback  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Wed May 10, 2017 1:12 pm 
Newbie


Joined:
Sat May 06, 2017 3:26 pm
Posts:
8
The egr has been blanked off. Do you think I should refit an egr valve


Offline
  Profile  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Thu May 11, 2017 3:06 am 
Silver Trader

Silver Trader

Joined:
Mon Feb 04, 2008 10:38 pm
Posts:
208
Nah, they cause a lot of grief - will cause a MIL light on the later engine management versions but wont otherwise do any harm.

Consider it one less thing to have to check...

_________________
DieselPowered Engine Tuning

Producing the highest power diesel rovers you're likely to see :D


Offline
  Profile Feedback  
 
 Post subject: Re: MG zs TD running problems
PostPosted: Sun May 14, 2017 10:10 am 
Newbie


Joined:
Sat May 06, 2017 3:26 pm
Posts:
8
I've sourced a maf just waiting for it to arrive drove to Wakefield yesterday and car was not happy every time I went over 3000 rpm did the car feel like it had no fuel and lost all power with a massive backfire like a petrol turbo would make. I'm really desperate for some help with this now I was thinking do you people think my timing could be out


Offline
  Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 14 posts ] 


 Who is online 

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

 
Index  |  FAQ  |  Search

Content © Rovertech - Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group